Tshoot 300-135 (Routing EIGRP)

EIGRP, OSPF & Redistribution

Ticket #1

R1 and R3 are not forming an EIGRP adjacency. Diagnose and resolve

R1#show ip eigrp neighbors
R1#show ip protocols
R1#ping 13.13.13.2
R1#show cdp neighbors
R1#show ip eigrp int detail gi3/0
R1#show key chain

#### Check key-chain on the neighbor R3
R3#show ip eigrp 1234 int detail gi1/0
R3#show key chain

#### Discovered that key chain index is different. Time to fix ###
R1(config)#key chain EIGRP_KEY
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string CCNP

#### Verify neighbor
R1#show ip eigrp neighbors

Ticket #2

R2 is not forming an EIGRP adjacency with R1 and R4.
Diagnose and resolve

R2#show ip eigrp neighbors
R2#show ip protocols
R2#show ip int br
R2#ping 12.12.12.1
R2#show arp 12.12.12.1
### Bring up administrative down interface on R1
R1(config)#int gi2/0
R1(config-if)#no shut
show ip protocols to compare the Metric weight
#### Remove existing metric weights to restore to default
R2(config)#router eigrp 1234
R2(config-router)#no metric weights
#### Verify that EIGRP is running for AS 1234 on Gi4/0
R2#show ip eigrp interfaces
R2#show ip eigrp interfaces detail
R2#show ip eigrp interfaces detail gi4/0
### Correct the network statement for EIGRP 1234
R4#show ip protocols
R4(config)#router eigrp 1234
R4(config-router)#network 24.24.24.0 0.0.0.3
Give correct wild card bits for /30 255.255.255.252

Ticket #3

Serveral EIGRP routes on R2 repeatedly disappear and reappear.
Diagnose and resolve

R2#debug ip routing
R2#clear log

### Check the Hello interval 
R2#show ip eigrp interfaces detail
R1#show ip eigrp interfaces detail
Go to neighbor and set to same Hello interval
R1(config)#int gi2/0
R1(config-if)#ip hello-interval eigrp 1234 5

### Check neighbor's Uptime
R2#show ip eigrp neighbors

### Check ip routing aged time
R2#show ip route

Ticket #4

R1 is not receiving non-connected routes.
Ensure that R1 receives EIGRP routes from R2 and R3

R1#show ip eigrp accounting
R1#show ip eigrp topology
R1#show ip protocols
There is ACL applied to Incoming
#### Verify that there is ACL applied
R1#show run | sec router eigrp
Confirm if distribute-list exists
R1#show access-lists 50
Able to confirm that neighbor is working well and there is incoming traffic
#### Remove the distribute list
R1(config)#router eigrp 1234
R1(config-router)#no distribute-list 50 in

Ticket #5

The 34.34.34.0/30 prefix doesn’t appear in IP routing table of R1 or R2. Diagnose and resolve

#### Verify the reported trouble
R1#show ip route 34.34.34.0 longer-prefixes
R1#show ip eigrp topology

R2#show ip route 34.34.34.0 longer-prefixes
R2#show ip eigrp topology

#### Check if any of R1 or R2 has distribute-list
R1#show run | sec router eigrp
R1#show ip protocols

R2#show run | sec router eigrp
R2#show ip protocols
#### Investigate further into R3
R3#show ip route 34.34.34.0 longer-prefixes
R3#show ip route 34.34.34.0
R3 belongs to two AS 1234 & 13
#### Discovered that R3 has another AS 13
R3#show run | sec router eigrp
R3#show ip protocols
#### Remove network statement from wrong AS 13
R3(config)#router eigrp 13
R3(config-router)#no network 34.34.34.1 0.0.0.0
R3(config)#router eigrp 1234
R3(config-router)#network 34.34.34.1 0.0.0.0

#### Do the same on the neighbor R4
R4(config)#router eigrp 13
R4(config-router)#no network 34.34.34.2 0.0.0.0
R4(config)#router eigrp 1234
R4(config-router)#network 34.34.34.2 0.0.0.0

#### Confirm the neighbor relationship
R3#show ip eigrp neighbors
R4#show ip eigrp neighbors

Ticket #6

Traffic from R2 takes a suboptimal path to 34.34.34.2 address on R4. Ensure that R2 takes the shortest path

#### Check which path R2 is taking
R2#traceroute 34.34.34.2 probe 1
R2#show ip route 34.34.34.2
R2#show ip eigrp topology 34.34.34.0/30

#### Found the reason why R2 is taking sub optimal path
#### The neighbor 24.24.24.2 is advertising only 1 Prefix
R2#show ip eigrp neighbors detail
R2#show ip route | i via 24.24.24.2
Neighbor 24.24.24.2 (R4) is advertising only 1 Prefix
#### The neighbor 24.24.24.2 (R4) is also a Stub 
#### Double check that R4 is indeed Stub
R4#show ip protocols
#### Check R4's configuration
R4#show run | sec router eigrp
#### Remove the eigrp stub
R4(config)#router eigrp 1234
R4(config-router)#no eigrp stub
#### Why is R2 still taking sub optimal path?
R2#show ip eigrp topology 34.34.34.0/30
R2#show ip route 34.34.34.0
Path to 12.12.12.1 (R1) still has lower feasible distance which is a problem
#### R2 still taking sub optimal path
R2#traceroute 34.34.34.2 probe 1
R2 is still taking sub optimal path via 12.12.12.1 (R1)
#### Discovered that FD(2816) of R4 does not match on R2.
#### FD of R4 != R2's AD 
R4#show ip eigrp topology 34.34.34.0/30
R2#show ip eigrp topology 34.34.34.0/30
#### Check if R4 has any offset-list
R4#show run | sec router eigrp

#### Check if the offset list hits any ACL
R4#show access-lists 30

#### Remove offset-list from source router R4
R4(config)#router eigrp 1234
R4(config-router)#no offset-list 30 out
#### Verify the AD after removing the offset-list
R2#show ip eigrp topology 34.34.34.0/30
R2#traceroute 34.34.34.2 probe 1

Ticket #7

R2 takes a sub optimal path to R4’s loopbacks 4.0.0.1, 4.0.0.2, 4.4.4.4/32
Ensure R2 takes the shortest path to these loopbacks.
Do not increase the number of prefixes advertised from R4

#### Check the sub optimal path and verify
R2#traceroute 4.0.0.1 probe 1
R2#traceroute 4.0.0.2 probe 1
R2#traceroute 4.4.4.4 probe 1
R2#show ip route 4.0.0.0
Router chooses more specific route vs summary route
#### Verify that R4 has route summarization
R4#show ip protocols
#### Verify the manual summarization
R4#show run int Gix/x
#### Advertise out the summarized route to both R2 & R3
R4(config)#int gi0/2
R4(config-if)#ip summary-address eigrp 1234 4.0.0.0 255.0.0.0
R4(config)#int gi0/3
R4(config-if)#ip summary-address eigrp 1234 4.0.0.0 255.0.0.0
##### Verify that R2 now has only 1 summarized rout
R2#show ip route 4.0.0.0

Leave a Reply

Your email address will not be published. Required fields are marked *

Scroll to top